
How to run the “Pokémon Plays Twitch” polyglot

On an emulator
You can play the PoC‖GTFO 10 polyglot on a modi-
fied lsnes with the hybrid emulation core using bsnes
and Gambatte. Figure 1 contains some compilation
notes, based on a chrooted installation of Debian
Stretch. This requires about 3Gb of free space. Skip
chroot instructions and adjust paths and users ac-
cordingly if you prefer to mess with your primary
OS.

And for the lucarnes amateurs, you may down-
load and run lsnes-rr2-beta23-installer.exe
from TASVideos1 and install it.

Then you’ll need to drop the two required
ROMs in the rom directory: “Super Game
Boy”2 as sgb.sfc and “Pokemon - Red Version
(USA_Europe).gb”3, as well as pocorgtfo10.pdf
renamed as pocorgtfo10.lsmv somewhere in the
chroot.

Fire up lsnes with the Gambatte plugin.

. / l s n e s −− l i b r a r y=gambatte/ core . so

Equivalently, under Windows: run C:\Program
Files (x86)\lsnes\lsnes-bsnes.exe, then File
→ Load → Load dynamic link library → core.dll

Adjust the ROM paths in Configure → Settings
→ Advanced: set Paths → firmware and Paths →
ROMs to the rom directory. Open the movie: File
→ Load → Movie → pocorgtfo10.lsmv and select
proposed ROMs. Then SGB→ Unpause and enjoy!

On real hardware
If you’re the happy owner of a Super Nintendo, a Su-
per Game Boy adapter and a Pokémon Red Game
Boy cartridge as shown in Figure 3, you might as
well run it on real hardware. You’ll need some
additional hardware; currently, the only hardware
that can handle the timing requirements of execut-
ing this exploit on a real console is the NES/SNES
replay device from true4 (although it is currently
available primarily in kit form). You will also need
to build wiring harnesses for two 7-wire controllers,

which will likely require three SNES controllers (the
third controller used as a donor for extra wires; it’s
a cheaper option than buying a real MultiTap de-
vice just for its cables). Finally, unless you have
fast enough reflexes to reset the console within a 20
ms window during the game save sequence it is wise
to connect a wire from pin 4 of the ISCP header on
the replay device to the reset pin on the SNES (pin
19 on the expansion header on the underside of the
console).

Rather than explaining how to use the bot in de-
tail we’ll instead defer to the documentation5 which
explains the basics.

In the original presentation there were two r16m
files6. The first file completed Stage 0 and triggered
the reset on the final frame through the use of a
specific flag (ser.write("∼W"), see below.) The
second one completed the remaining stages through
the end of writing the Twitch chat client.

Because the payload created for this article is
the article itself, it is packaged as a third r16m file,
which can be played back immediately after the sec-
ond r16m file to cause the article text to appear in
the chat window at maximum speed. If the original
Twitch interface is desired, a few extra scripts are
required as we’ll see later.

We could have included the r16m files in the
zip but that’s cheating, isn’t it? Instead we pro-
pose you to extract the r16m files from the lsmv
polyglot itself. Take note that this is not for the
faint of heart as it requires a fair bit of effort
and some stitching due to the bsnes SGB emula-
tion being inaccurate compared to real hardware.
You’ll need both the lsnes_dump_frames.lua and
lsnes_dump_latch_subf.lua scripts7.

Start by loading the polyglot in lsnes as a movie
as described in the previous section8. By the way,
at each edge of dumping the movie it is advisable to
Save → State. . . so you can go back to that point
later.

Load the first Lua script: Tools → Run Lua
script. . . → lsnes_dump_frames.lua. Execute in

1http://tasvideos.org/Lsnes.html
2SHA-256: BBA9C269273BEDB9B38BD5EB23BFAA6E509B8DECC7CB80BB5513905AF04F4CEB
3SHA-256: 5CA7BA01642A3B27B0CC0B5349B52792795B62D3ED977E98A09390659AF96B7B
4http://truecontrol.org
5https://svn.truecontrol.org/tasbot/nes-snes-replay/trunk/nes-snes-replay.X/readme.txt
6The r16m files consist of a bitstream of each button on each controller to press.
7unzip -j pocorgtfo10.pdf pokemon_plays_twitch/lsnes_dump*.lua
8If you don’t have the required ROMs, since you own the real hardware, you can use e.g. savestates to extract them yourself.
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1 # cf h t t p s :// wik i . debian . org/ chroot
sudo apt−get i n s t a l l b i n u t i l s debootst rap

3 mkdir −p /path/ to / chroot−s t r e t c h
sudo debootst rap s t r e t c h /path/ to / chroot−s t r e t c h

5 sudo chroot /path/ to / chroot−s t r e t c h
cat > ./ usr / sb in / po l i cy−rc . d <<EOF

7 #!/ bin /sh
exit 101

9 EOF
chmod a+x ./ usr / sb in / po l i cy−rc . d

11 dpkg−d i v e r t −−d i v e r t / usr / bin / i s c h r o o t . d e b i a nu t i l s −−rename / usr /bin / i s c h r o o t
ln −s / bin /true / usr / bin / i s c h r o o t

13
apt−get i n s t a l l g i t make gcc g++ g++−4.9

15 apt−get i n s t a l l z l i b1g−dev l i b sws ca l e−dev portaudio19−dev l ibao−dev lua5 . 2 l i b l u a 5 .2−dev \
l i b c u r l 4−openss l−dev l ibgc rypt20−dev l ibwxgtk3 .0−dev l i bboo s t 1 .58−dev \

17 l i bboo s t−i o s t r eams1 .58−dev l i bboo s t−f i l e s y s t em1 .58−dev
cd

19 g i t c l one http :// repo . or . cz / l s n e s . g i t
mkdir gambatte && cd gambatte

21 mkdir l sne s−core
# bb5cd617cb396d11415de7a4af6ab170a7d84136 from exp/gambatte−bsnes−sgb

23 g i t −C . . / l s n e s a r ch ive bb5cd617cb396d11415de7a4af6ab170a7d84136 | \
ta r −xf − −C lsne s−core

25 mkdir −p l sne s−core / bsnes
# 8 f448c3061eef5 f faae2b2235d22be3453708f75 from exp/bsnes−ext−gb

27 g i t −C . . / l s n e s a r ch ive 8 f448c3061ee f5 f faae2b2235d22be3453708 f75 | \
ta r −xf − −C lsne s−core / bsnes

29 mkdir −p l sne s−core /gambatte
# 705 b3154f683a42c245602a9e66b0b6c71e101df from exp/gambatte−sgb

31 g i t −C . . / l s n e s a r ch ive 705 b3154f683a42c245602a9e66b0b6c71e101df | \
ta r −xf − −C lsne s−core /gambatte

33 mkdir −p l sne s−core / bsnes / obj l sne s−core / bsnes /out
make −C lsne s−core

35 cd
cp gambatte/ l sne s−core / core . so l s n e s /gambatte/ && rm −r f gambatte

37 cd l s n e s
g i t checkout 610685 db0fc4565 f25772ea f f2ad47e268 fd2a41 # ju s t to be sure

39 g i t a r ch ive d39571de650d49636778a73c66414af f372c08af | t a r −xf − −C bsnes
sed − i ’ s /^LUA=.∗/LUA=lua5 . 2/ ’ opt ions . bu i ld

41 make
mkdir rom

Figure 1 – Compilation notes for Debian Stretch in Chroot
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Figure 2 – PoC‖GTFO 10:3 displayed in lsnes, with 4 controllers using sub-frames

Figure 3 – Exploit with extra credits shown by a real SNES via TASBot
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the text box at the bottom of the lsnes Messages
window:

L start_dump ( "PPTStage0" )

Go to Tools→ Edit Movie. . . , right-click in the first
column and select Run to frame. . . . Enter 3457 and
hit OK. The movie will play until it reaches the point
directly after the reset. Save the dumped movie by
executing

L stop_dump ( )

which should produce the message “Dumping
halted”. If everything worked correctly, the result-
ing file9 will be created in the working directory of
lsnes.

Stage 1 will require creating two separate r16m
files which will be recombined along with the Stage 2
movie later. While still on frame 3457, execute

L start_dump ( "PPTStage1P1" )

and use the same method as before to run up to
frame 11992 and stop the dump.

L stop_dump ( )

We have to stop here because at this point we
need to remove 9 frames of empty input to cor-
rect for inaccuracies with the bsnes core’s emula-
tion of the clock skew/slip. Use the same Run
to frame. . . method to advance 9 frames to frame
12001. From here we can dump the second portion
of Stage 1:

L start_dump ( "PPTStage1P2" )

and run through to frame 12116 then

L stop_dump ( )

The movie will pause at the end of the Stage 1
payload execution, right after Stage 2 is written one
nibble per frame.

The next portion needs to switch to a script
that will record one latch per poll which will al-
low the datarate to increase beyond one controller
read per frame in later stages. To switch scripts,
go to Tools → Reset Lua VM to clear out the
frames version then Tools → Run Lua script. . . →
lsnes_dump_latch_subf.lua.

As before, type

L start_dump ( "PPTStage2" )

Run to frame 13273, then

L stop_dump ( )

One could stop slightly before this point but if
we stop too quickly after the payload is written we
will see a repeating buffer of garbled text as was
the case during the first AGDQ 2015 presentation;
the extra tail here ensures the hardware buffer in
the replay board has a consistent stream of empty
input.

Concatenate the two portions of Stage 1 and
Stage 2 into a single file10:

cat PPTStage1P1 . frame . r16m PPTStage1P2 . frame
. r16m PPTStage2 . l a t s f . r16m >
PPTStage1and2 . r16m

We now have the entire payload up to the point
where the Twitch chat interface is visible, albeit with
no text in the chat area.

It’s now possible to take this state and start feed-
ing the article or get some IRC chat text in live.

But feeding directly the recorded IRC chat as
available in the polyglot would result in some dupli-
cate input when played on a real console because it
was made to handle lag frames in a way that it looks
correct on the emulator but which when re-dumped
and played on a real console the same characters are
sent more than once.

To avoid this, run forward to frame 27780 with-
out dumping a movie.

To extract the payload:

L start_dump ( "PPTStage6" )

and run to the final frame 29535, then:

L stop_dump ( )

To replay r16m files, connect the replay board to
a properly populated SNES console with the afore-
mentioned wiring harnesses consisting of all 7 wires
for both controller ports. The replay device detec-
tion tends to be somewhat finicky when using the
serial over USB interface (i.e. connecting the replay
board to a computer with a USB cable rather than
using the raw serial pins in the corner of the board),
so ignore any “Replay device not found” or similar
messages you may see in the steps below.

We’ll use the official replay.py11 and a modified
copy replay_reset.py with the following addition:

9SHA-256: DBACF452D63F833E7E93148C5421DA4BC95B4386157CD4B5CA5E31C1B919CB38
10SHA-256: 0A455C67B29A9ACBA66F78ACDD18840A3EFFDFA6E1C74BA03EC4FB3ACFE4359A
11unzip -j pocorgtfo10.pdf pokemon_plays_twitch/replay*.py
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@@ −118 ,2 +118 ,3 @@
se r . wr i t e ( "~v" ) # po l l f o r ver s ion

+se r . wr i t e ( "~W" ) # re s e t ISCP f l a g
time . s l e e p ( 0 . 0 3 ) # usb f i x

The first replay run will look like this:

python rep lay_rese t . py PPTStage0 . frame . r16m
/dev/ttyACM0 0 t 180

If everything is connected properly the script will
say “Resetting. . . ” and will wait for the console to
be turned on. Make sure a copy of Pokemon Red is
inserted inside of an SGB cartridge and the Poke-
mon Red save game has been deleted12.

If you choose using a reset wire, make sure it is
properly connected as described above. Otherwise,
to do the reset by hand, practice powering off the
console at the correct time by playing through that
section of the movie with the emulator a few times
to memorize the timing.

Once all conditions are met, turn on the console
to start replaying the movie. The rival should then
be named RxRx

PK

; if things go wrong, menu naviga-
tion will be noticeably slower than what you would
see on the emulator. At the end of the movie, if the
reset wire is present and working the SNES will lock
up.

You’ll have an intact save file that reports that
you have 0 Pokemon and you will be able to enter
the Pokemon menu and navigate around in empty
white space if everything went as expected. From
here on out, you won’t need the reset pin and any
further testing should probably be done without go-
ing through this section again.

Because of the pesky timing change between
frame mode and latch mode, we can’t use the stan-
dard replay.py. Instead, we’ll use the scripts from
the PptIrcBot repository, which are also available in
the feelies13 and use the replay_switch.py script
to run through the stages.

python replay_switch . py PPTStage1and2 . r16m /
dev/ttyACM0 0 t 180

This should reach the point of an empty Twitch
chat interface. You can immediately run the full
article text:

python replay_stream2 . py PPTStage6 . l a t s f .
r16m /dev/ttyACM0 0 1 180

Or you can be even more adventurous and pipe
the Internet to your SNES! You can optionally
alter settings.yaml to your liking, potentially
edit themicrobot.py and comment out the line
self.ircBot.connection.privmsg(IrcChannel,
text) near line 113 to prevent RED’s text from
being sent into the actual IRC channel, then run

python themicrobot . py

in one terminal,

python readpipe . py tasbot_pipe

in another one (to see what TASBot will be saying),
and the following in a third one:

touch empty f i l e . r16m
python replay_stream2 . py empty f i l e . r16m /dev

/ttyACM0 0 1 180

If all goes well, your bot user should join the IRC
channel you specified and you should hear TASBot
speak (assuming you have espeak installed) while
the screenplay plays back on your console. More
amusingly as demonstrated in the console verifica-
tion video14, you can now type whatever you want
in the IRC channel and it will be displayed in the
SNES Twitch chat interface, even in the middle of
replaying the screenplay. While some of the things
are clearly a bit contrived (the “web view” shown
in the screenplay is nothing more than a carefully
palletized screenshot of TASVideos.org, Twitch chat
never actually had any influence on the color of the
site as shown on the SNES when it was flashing, and
we weren’t able to finish the camera code in time to
make the actual AGDQ 2015 serial-attachable cam-
era function), it’s still an impressive feat seeing a
game console from 1990 connected to the Internet
using only the controller ports.

12To show the hidden delete menu, press Select+Up+B when the Title screen is displayed
13unzip -j pocorgtfo10.zip pokemon_plays_twitch/PptIrcBot.zip && unzip PptIrcBot.zip
14https://youtu.be/NTzrbhCTEhw
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